Не работает мультизагрузка фото

 
Посетитель
no avatar
Сообщений: 69
Здравствуйте! У меня такая проблема - не могу загрузить фотографии через мультизагрузку. Выдает ошибку 302. В чем может быть проблема? Я предполагаю, что на какие то папки выставлены неверные права, а вот на какие понятия не имею. Может кто подскажет???
Прикрепленные файлы:
screen_22913.jpg | 29.6 Кб | Скачали: 746
Редактировалось: 1 раз (Последний: 20 августа 2011 в 09:41)
Мои сайты:
Мой блог
www.spravkapc.ru - Справочник ПК
www.ourkoshki.ru - Все о кошках
Посетитель
small user social cms
МедальКубок зрительских симпатийПочетный донор проекта
Сообщений: 828
Нужно добавить в .htaccess строку
SecFilterEngine Off
Видимо какая то защита стоит на сервере например Suhossin
Реклама
cms
Посетитель
no avatar
Сообщений: 69
maxisoft:
Нужно добавить в .htaccess строку
SecFilterEngine Off
Видимо какая то защита стоит на сервере например Suhossin
Спасибо, помогло! dance
Мои сайты:
Мой блог
www.spravkapc.ru - Справочник ПК
www.ourkoshki.ru - Все о кошках
Посетитель
small user social cms
Сообщений: 20
У меня ошибку 500 выдает при мультизагрузке, помогите исправить пожалуйста!
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
Annushka:
У меня ошибку 500 выдает при мультизагрузке,
то же самое
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
Вот что пробывал и не помогает:
права на upload и imeges + вложенные 755
----------
хитач в корне
Код PHP:
  1. <IfModule mod_security.c>
  2. <Files async-upload.php>
  3. SecFilterEngine Off
  4. SecFilterScanPOST Off
  5. </Files>
  6. </IfModule>
---------------------------
замена файлов из оригинала:
/includes/jquery/multifile/jquery.multifile.js

/templates/_default_/components/com_photos_add1.tpl
/templates/_default_/components/com_photos_add2.tpl
--------------------------------------------------
добавил в хитач в корне - SecFilterEngine Off - вообще сайт вылетае (интернал сервер эррор)
-----------------------------------------

по прежнему мультизагрузка в общих - ошибка 500
в личных - грузит фото но при продолжить - страница не найдена.
Где ещё искать ошибку?
Редактировалось: 3 раз (Последний: 21 ноября 2011 в 14:44)
Посетитель
small user social cms
Сообщений: 20
У меня все исправлено, небольшие неполадки были на сервере.
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
Annushka:
были на сервере.
написал только что хостеру. жду ответа.
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
хостер ответил что не имеет понятия в чём трабла
блин я уже не знаю что делать-то

может в хитач что не так
у меня в корне он вот так выглядит
Код PHP:
  1. AddDefaultCharset windows-1251
  2.  
  3.  
  4.  
  5. RewriteEngine On
  6. RewriteBase /
  7. RewriteRule ^.htaccess$ - [F]
  8.  
  9.  
  10.  
  11. RewriteCond %{HTTP_HOST} ^www.сайт\.ru$ [NC]
  12. RewriteRule ^(.*)$ http://сайт.ru/$1 [R=301,L]
  13.  
  14.  
  15.  
  16.  
  17. RewriteCond %{REQUEST_URI} !\.(jpg|jpeg|ico|gif|png|css|xml|js|pl|txt)$ [NC]
  18. RewriteCond %{REQUEST_FILENAME} !^/admin
  19. RewriteCond %{REQUEST_FILENAME} !^/migrate
  20. RewriteCond %{REQUEST_FILENAME} !^/install
  21. RewriteCond %{REQUEST_FILENAME} !-f
  22. RewriteCond %{REQUEST_FILENAME} !-d
  23.  
  24. RewriteRule ^(.*)$ /index.php [L]
  25.  
  26. <IfModule mod_security.c>
  27. <Files async-upload.php>
  28. SecFilterEngine Off
  29. SecFilterScanPOST Off
  30. </Files>
  31. </IfModule>
  32.  
Редактировалось: 1 раз (Последний: 21 ноября 2011 в 14:43)
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
причём при мультизагрузке фото в профиле они попадают в папки imeges/users/photos/medium и small , почему же при нажатии продолжить - вылетает - Страница не найдена или не существует.
???
на другом сайте на этом же хосте тот же движок 1.7->1.8
всё работает
так же вот этот файл заменил с оригинала com_users_photo_add.tpl и всё равно выкидывает на страница не существует
Редактировалось: 2 раз (Последний: 21 ноября 2011 в 16:26)
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
Annushka:
У меня все исправлено, небольшие неполадки были на сервере.
какого рода неполадки?
Посетитель
small user social cms
Сообщений: 20
какого рода неполадки?
я не вдавалась в подробности, исправилось и хорошо look
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
А вот теперь самое странное...
Есть четыре пользователя для тестов. И через одного из них мультизагрузка включается, а через других включая админа -НЕТ!. Как это может быть? shock
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
и те фото которые не удалось загрузить мультизагрузкой у других - появляются у этого юзера в листе ожидания на загрузку! т.е чужие фото которые не смогли загрузить из профиля и выскочила несуществующая страница - эти фото появляются у этого единственного у которго мульт загрузка почему-то работает.... ёлки палки что это? Аларм!
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1133
чем дальше в лес... теперь в клубах по мультизарузке стали добавляться фото, но теперь любой юзер загрузивший в клуб по мульту - его фото постятся от имени того единственного юзера про которого говорил выше. Т.е любой грузит а в результате публикуется от имени другого.
Буду ставить 1.9. Посмотрим может поможет а то уже мультзагрузка на грани фантастики и никто ничего подсказать не может
Редактировалось: 2 раз (Последний: 22 ноября 2011 в 12:17)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.