[РЕШЕНО] Аватар в профиле пользователя 2.X

 
Посетитель
small user social cms
Сообщений: 10
Всем привет! Не знаю когда случилось это, но в данный момент такая проблема, после того как пользователь зарегистрировался на сайте, у него на месте аватара как будто битая картинка, скрин прикрепляю к теме, как выправить данную проблему? Буду очень признателен!
Версия системы: 2.9.0
Прикрепленные файлы:
_1hk91.png | 11,31 Кб | Скачали: 36
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1123
MrDinesh, Попробуйте в админке:
Компоненты: Профили пользователей / Аватар
выставить все галки в "Создавать превью-изображения"
Посетитель
small user social cms
Сообщений: 10
Sonat:

Компоненты: Профили пользователей / Аватар
выставить все галки в "Создавать превью-изображения"

Выставил все галки, но проблема не была решена, кэш браузера чистил, есть еще предложения?
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1123
MrDinesh:
Выставил все галки, но проблема не была решена, кэш браузера чистил, есть еще предложения?
После этого аватар загружали? или просто проверили а не появился ли он сам? hoho

Еще предложение проверить права на папки куда грузятся аватарки
Посетитель
small user social cms
Сообщений: 10
Sonat:

После этого аватар загружали? или просто проверили а не появился ли он сам? hoho

Еще предложение проверить права на папки куда грузятся аватарки

Аватар я не загружал, а просто создал еще одного пользователя, но такая же проблема, аватарки если загружать самому, все грузиться отлично, проблема заключается в том что при создании нового пользователя, у всех новых пользователей такая проблема, но когда пользователь загружает свое лого, все становиться отлично:) права на папки выставлены правильно.
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1123
MrDinesh:
у всех новых пользователей такая проблема, но когда пользователь загружает свое лого, все становиться отлично
Ааа, т.е. проблема в том что еще до загрузки аватарки нет заглушки?

Скорее всего нет файла-изображения заглушки
Проверьте в коде откуда должна грузиться на страницу картинка которая битая
и подставьте туда нужный файл


На дефолте это /upload/default/avatar.jpg
Редактировалось: 1 раз (Последний: 13 января 2018 в 17:26)
Посетитель
small user social cms
Сообщений: 10
Sonat:

На дефолте это /upload/default/avatar.jpg

Нашел причину почему такая проблема, все из-за того что я изменил в поле "аватар" Размер в записи из Средний у которого Системное имя "normal" на свое созданное Аватар профиля у которого системное имя "avatar_profile". При замене обратно на Средний аватар становиться нормальным.

Теперь Вопрос такой, почему реагирует только на системное имя "normal" как изменить что бы реагировало на системное имя "avatar_profile"?
Возможно в каком то файле прописано что аватар берется из системного имени "normal"?
Посетитель
small user social cms
Медаль
Сообщений: 112
MrDinesh, templates/нужный_шаблон/controllers/users/какой то файл, имя вспомнить не могу
На сколько знаю, да, там выводится normal
Помог? Вместо "спасибо" - плюс в профиль.
Посетитель
small user social cms
Сообщений: 10
Developper:

templates/нужный_шаблон/controllers/users/какой то файл, имя вспомнить не могу
На сколько знаю, да, там выводится normal

Возможно, в файле styles.css там есть такое значение как normal.

Проблему решил следующим образом, моему созданному полю Аватар профиля у которого было системное имя "avatar_profile" я изменил это имя на "normal" а оригинальное системное имя изменил на "normals" соответственно аватар уже становиться таким каким должен быть.

Всем спасибо, всем добра:)
В начало страницы
Предыдущая темаПерейти на форум: