InstantCMS в хостинг панели BRAINY

 
Посетитель
small user social cms
Медаль
Сообщений: 272
yum update можно спокойно делать? Ничего не отвалится в ПУ после обновления всего ПО на сервере?
Хостинг с крутой Панелью управления, бесплатными Сертификатами и его Преимущества
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
BoAnRo:
yum update можно спокойно делать? Ничего не отвалится в ПУ после обновления всего ПО на сервере?
Не пробовал! По идее UPDATE не должно переписывать конфиги!
Но перед UPDATE все же рекомендовал бы сделать бэкапы на удаленном носителе! Если что не так, можно достаточно оперативно все восстановить на свежую систему!
То есть: ставим CentOS 7 (mini), потом инсталлируем Brainy и после входа в панель восстанавливаем все из бекапов

Кстати, после любых настроек в php.ini, обновлении или установке программ рекомендую жать на кнопочку Перегрузить виртуальные хосты - это в в самом низу по пути Вебсервер - Установка вебсервера
Редактировалось: 1 раз (Последний: 1 января 2018 в 13:53)
Недорогой и мощный хостинг для InstanCMS
Посетитель
small user social cms
Медаль
Сообщений: 272
С yum update все оказалось сложно.

После yum update получаю в конце вывода результата выполнения команды ошибки такого вида:
Код PHP:
  1. Помилка: Пакунок: clamd-0.98.4-3.el7.centos.x86_64 (@myrepo-centos)
  2. Потребує: libclamav.so.6()(64bit)
  3. Вилучення: clamav-0.98.4-3.el7.centos.x86_64 (@myrepo-centos)
  4. libclamav.so.6()(64bit)
  5. Оновлено: clamav-0.99.2-13.el7.x86_64 (epel)
  6. Не знайдено
  7. Наявні: clamav-0.98.4-1.el7.centos.x86_64 (myrepo-centos)
  8. libclamav.so.6()(64bit)
  9.  
  10. Помилка: Пакунок: cairo-1.14.8-2.el7.x86_64 (@base)
  11. Потребує: libEGL.so.1()(64bit)
  12. Вилучення: 1:libglvnd-egl-0.2.999-10.gitdc16f8c.el7.centos.x86_64 (@myrepo-centos)
  13. libEGL.so.1()(64bit)
  14. Оновлено: 1:libglvnd-egl-1.0.0-1.el7.x86_64 (epel)
  15. Не знайдено
  16. Наявні: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (base)
  17. libEGL.so.1()(64bit)
  18. Встановлено: mesa-libEGL-17.0.5-10.el7.centos.x86_64 (@myrepo-centos)
  19. Не знайдено
  20. Наявні: mesa-libEGL-17.0.0-6.el7.centos.x86_64 (myrepo-centos)
  21. Не знайдено
Но если даже ввожу yum update --skip-broken

получаю:
Код PHP:
  1. Пакунки, пропущені через проблеми з залежностями:
  2. clamav-0.99.2-13.el7.x86_64 з epel
  3. clamav-data-0.99.2-13.el7.noarch з epel
  4. clamav-filesystem-0.99.2-13.el7.noarch з epel
  5. clamav-lib-0.99.2-13.el7.x86_64 з epel
  6. 1:libglvnd-1.0.0-1.el7.x86_64 з epel
  7. 1:libglvnd-egl-1.0.0-1.el7.x86_64 з epel
  8. 1:libglvnd-glx-1.0.0-1.el7.x86_64 з epel
и при подтверждении установки доступных пакетов ошибки вида:


Код PHP:
  1. Is this ok [y/d/N]: y
  2. Downloading packages:
  3. Running transaction check
  4. Running transaction test
  5.  
  6.  
  7. Transaction check error:
  8. file /usr/bin/ab from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  9. file /usr/bin/htdbm from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  10. file /usr/bin/htdigest from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  11. file /usr/bin/htpasswd from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  12. file /usr/bin/httxt2dbm from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  13. file /usr/bin/logresolve from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
  14. file /usr/share/man/man1/ab.1.gz from install of httpd-tools-2.4.6-67.el7.centos.6.x86_64 conflicts with file from package httpd24-tools-2.4.24-15.el7.centos.x86_64
Ответ службы поддержки Brainy был:
Наш репозитарий не совместим с репозитарием EPEL. Вы можете ставить только выборочно отдельные пакеты, а не все пачкой через yum update.

В общем получается, что обновлять нормально ОС и всякое ПО, которое устанавливалось не с репозитария Brainy, будет сложновано. Разбираться выборочно с отдельными пакетами слишком накладно.

В других ПУ тоже встречаются такого типа проблемы учитывая, что в некоторых (например, ispmanager) тоже есть свои репозитарии с ПО? В VestaCP, как я понял по информации в Интернете, нет своих репозитариев.
Хостинг с крутой Панелью управления, бесплатными Сертификатами и его Преимущества
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
BoAnRo:
В общем получается, что обновлять нормально ОС и всякое ПО, которое устанавливалось не с репозитария Brainy, будет сложновано. Разбираться выборочно с отдельными пакетами слишком накладно.
Давайте рассуждать логически:
1. После инсталляции CentOS 7, если вы считаете, что в сборке устаревшие пакеты, тогда вы можете сразу апгрейдить систему, до установки панели. Как минимум на год работы этого достаточно.
2. Панель Brainy - это целый программный комплекс, имеющий изначальные настройки. За актуальность входящих в него программ следят разработчики панели и они же следят за их работоспособностью! Что лично меня полностью устраивает. Поэтому самому лезть в обновление программ, входящих в панель просто не стоит.
3. Изначально Brainy дает право выбора, что устанавливать из подготовленных ими пакетов. Как писалось выше, каждый пакет интегрирован в панель, а не просто лежит в исходнике.
4. В связи с вышеизложенным репозитатий Brainy действительно должен иметь свои особенности.Позволяет переустанавливать и менять пакеты в пределах репозитария.
5. Если уж совсем все плохо, то Brainy позволяет достаточно быстро сделать переустановку всего ВПС с восстановлением ранее сделанных настроек.
Редактировалось: 1 раз (Последний: 5 января 2018 в 02:33)
Недорогой и мощный хостинг для InstanCMS
Посетитель
small user social cms
Медаль
Сообщений: 272
Как минимум на год работы этого достаточно.
Вряд ли, учитывая то, что часто выходят обновления безопасности ОС. Поэтому важно чтобы в любой момент была возможность обновить систему простым yum update

Причиной проблемы было то, что ОС которая была установлена у меня, видимо была не "чистой". Так как в ней уже был подключен репозитарий EPEL, который не должен быть подключен в чистой CentOS. Если удалить этот конфликтующий с Brainy репозитарий, тогда все обновляется через yum update без проблем. Так что проблемы с обновлением нет.

Эта тема обсуждалась у них на форуме https://community.brainycp.com/viewtopic.php?f=7&t=466&p=793&hilit=пакетный#p793 Мне нужно было сразу там поискать.

Теперь у меня остается еще проблема с ClamAV который почему-то не хочет запускаться с ПУ. И наверно нужно поменять порт для ssh так как по нему ломятся на сервер каждый день (по несколько сотен неудачных авторизаций). Но с этим разбираться уже буду позже.
Редактировалось: 1 раз (Последний: 6 января 2018 в 02:38)
Хостинг с крутой Панелью управления, бесплатными Сертификатами и его Преимущества
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
BoAnRo:
И наверно нужно поменять порт для ssh так как по нему ломятся на сервер каждый день (по несколько сотен неудачных авторизаций).
Порт можно SSH меняется прямо из панели Приложения - SSH сервер
Затем порт надо прописать в файерволе.
Добавляем нужный порт через iptables
iptables -A INPUT -p tcp --dport 465 -j ACCEPT где 465 порт (заменить на ваш)
Недорогой и мощный хостинг для InstanCMS
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
По работе и настройке с IPTABLES советую эту статью, Если кто то найдет что то получше, предлагайте.
Недорогой и мощный хостинг для InstanCMS
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1581
vikont:
Если кто то найдет что то получше, предлагайте.
Установил вчера на тестовый сервер ISPmanager триальный. Рыдал в ностальгии.
Все сильнее подмывает купить вечную лицензию ISP за 2000 и не мучиться...
Посетитель
small user social cms
Медаль
Сообщений: 272
Ris:

Все сильнее подмывает купить вечную лицензию ISP за 2000 и не мучиться...

И как только выйдет новая мажорная версия ispmanager и через короткое время прекратится поддержка старой версии "вечную лицензию" можно выкидывать, так как толку с нее не будет при отсутствии обновлений ПУ и соответственно незакрытых дыр в безопасности.
Хостинг с крутой Панелью управления, бесплатными Сертификатами и его Преимущества
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
Ris:
Установил вчера на тестовый сервер ISPmanager триальный. Рыдал в ностальгии.
У Brainy 2 проблемы:
1. панели нет еще и года
2. мы слишком много узнаем такого, о чем тихо молчат в ISP и все проблемы на себя берет техподдержка.
После Brainy, мне навряд ли захочется перейти даже на ISP не говоря уже о Весте..
Я не фанат Brainy, просто трезво оцениваю свои возможности в администрировании и то удобство, которое дает мне панель!
Недорогой и мощный хостинг для InstanCMS
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1581
BoAnRo:
И как только выйдет новая мажорная версия ispmanager и через короткое время прекратится поддержка старой версии
Согласен. Пройдет три года, я буду горько плакать о впустую потраченных деньгах и затыкать ватными палочками дыры в безопасности. facepalm
Но при этом панель будет работать! Шесть лет проработал сервер на айхоре без переустановки.

vikont:
Я не фанат Brainy, просто трезво оцениваю свои возможности в администрировании и то удобство, которое дает мне панель!
Я не фанат айэспе, но оно неубиваемое.
Бейни же умирает от громкого чиха при открытой в браузере панели.
Посетитель
small user social cms
Кубок зрительских симпатийМедальАвторитет форума
Сообщений: 5885
на сайте
vikont:
мы слишком много узнаем такого, о чем тихо молчат в ISP и все проблемы на себя берет техподдержка.

Например что?

Ris:
Установил вчера на тестовый сервер ISPmanager триальный. Рыдал в ностальгии.
Все сильнее подмывает купить вечную лицензию ISP за 2000 и не мучиться...

Есть на продажу 4 и 5 лицензии ISP недорого.

Ris:
Я не фанат айэспе, но оно неубиваемое.
Бейни же умирает от громкого чиха при открытой в браузере панели.

Согласен что ISP это уже продукт настоящий. Брайни пока бета и им еще год, а то и два надо для развития.
Редактировалось: 1 раз (Последний: 7 января 2018 в 00:51)
Хостинг и ВПС Халява тексты Стартапы UPDS - Instant
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1581
letsgo:
Брайни пока бета и им еще год, а то и два надо для развития.
Им бы еще разделить функционал на лайт и профи, как в ISP.
Пока для конечного пользователя функционал панели перегружен.
Посетитель
small user social cms
Медаль
Сообщений: 272
Теперь достаточно просто указать нужный порт. В iptables изменения вносить уже не нужно.
vikont:

Порт можно SSH меняется прямо из панели Приложения - SSH сервер
Затем порт надо прописать в файерволе.
Добавляем нужный порт через iptables
iptables -A INPUT -p tcp --dport 465 -j ACCEPT где 465 порт (заменить на ваш)
Редактировалось: 1 раз (Последний: Вчера в 12:33)
Хостинг с крутой Панелью управления, бесплатными Сертификатами и его Преимущества
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1047
BoAnRo:
Теперь достаточно просто указать нужный порт. В iptables изменения вносить уже не нужно.
Это верно! Разработчики постоянно работают над совершенствованием панели!
Недорогой и мощный хостинг для InstanCMS
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.