[РЕШЕНО] На сайте не отправляются письма через SMPT 2.X

 
Посетитель
small user social cms
Сообщений: 74
Всем привет. На сайте настроена почта через SMPT (авторизация + SSL шифрование), почтовый ящик на jino.ru. Всё работало чудно, но в какой-то момент я понял, что письма сайт не отправляет, проверил - выдаёт ошибку и шлёт на гитхаб в ВиКи: При отправке письма произошла ошибка:
Ошибка соединения с SMTP-сервером https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Я проверил на этом сайте другой почтовый ящик - он тоже не стал работать. Переключил настройки на Sendmail - и только после этого сайт начал отправлять письма. Но очень хочется обратно вернуть SMPT так как на сайте настроена рассылка по клиентам (KMailer) и все рекомендуют SMPT + возможность отписки по ссылке в письме (а то в спамеры определят и будут проблемы).

Я сомневаюсь, что проблема возникла после установки KMailer, и одна из рассылок была включена на момент сбоя SMPT, в итоге 8го числа люди письма получали и открывали и по ссылкам переходили на сайт, а вот уже 9го числа только переходили по ссылкам из писем от 8го числа. Письма которые были отправлены 9го и 10го (как я понимаю) на самом деле не отправлялись вообще...

Какие файлы нужно перезалить в движке, что бы устранить эту беду?
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проекта
Сообщений: 1097
Roman, нужны логи, в логах будет ошибка почему письма не отправляются. может быть вы в спамлистах?
Фриланс по Intantcms 1 и 2 версий.Писать в ЛС. Доступные VDS - реально даром
Посетитель
small user social cms
Сообщений: 74
От ТП хостинга пришел ответ: в настройках почтового ящика я сам снял галку SMPT (что-то там), вот и не работала почта на сайте))) Тему закрываю!
В начало страницы
Предыдущая темаПерейти на форум: