Тип поля "Набор изображений" не грузятся картинки

 
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проекта
Сообщений: 2822
Не загружаются изображения в типе поля "Набор изображений", якобы происходит загрузка (стрелочки крутятся возле имени картинки, а потом пропадают), картинки появляются в папке upload и все, на сайте их не видно, права на папку и вложенные папки upload - 755, тип поля "файл" работает исправно, в фотоальбомы грузится. Переустанавливал систему, на дефолтовых типах контента все работало, удалил не нужные, сделал свои типы контента - не работает. Версия 2.2.1.
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проекта
Сообщений: 2822
Попробовал еще на денвере, тоже не работает, еще на одном сайте который обновлен с 2.1.2 до 2.2.1 работает
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проекта
Сообщений: 2822
Эврика! Если долго мучатся, то что-нибудь получится, вообщем нашел баг, если в настройках поля "Набор изображений" убрать галочки с "Создавать превью-изображения" с пунктов: "Микро Маленький Средний Большой ". тогда картинки не грузятся. Также если их удалить в компоненте "Загрузка изображений" то картинки тоже не грузятся!

В общем, кто может попытайтесь повторить.
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проекта
Сообщений: 2822
up
Посетитель
no avatar
Сообщений: 35
Jestik:
если в настройках поля "Набор изображений" убрать галочки с "Создавать превью-изображения" с пунктов: "Микро Маленький Средний Большой ". тогда картинки не грузятся.

А еще при сохранении страницы выдает ошибку, пятьсот какую-то там. Не понятно почему так. Сам мучался с этим.
Посетитель
small user social cms
Медаль
Сообщений: 544
Внезапно, актуально.
если в настройках поля "Набор изображений" убрать галочки с "Создавать превью-изображения" с пунктов: "Микро Маленький Средний Большой ". тогда картинки не грузятся.
Именно так. Странно. Или они грузятся, но не выводятся на странице. Только если поставить везде галочки - все работает.
Посетитель
no avatar
Сообщений: 3
Нет решения? Работает только Размер в записи. При клике выводиться тот размер который в превью. Что за модуль такой?
Посетитель
small user social cms
Сообщений: 7
Помогите! Добавил в тип контента поле "Набор Изображений". Так вот почему то не работает попап - а перекидывает по ссылке картинки - на страницу с .jpg в конце ... Причем как то странно - в начале работал попап - и всплывала крупная фотка, а потом что то пошло не так - пробую в разных браузерах и нигде не работает, а в хроме работает - но я думаю это из-за кеширования какого то ((( 

upd. Короче говоря - начал я играться с настройками в полях и вроде заработало... Но всё равно - имеется какой то мелкий баг - логика которого пока не понятна ((
Редактировалось: 1 раз (Последний: 21 декабря 2017 в 00:43)
Посетитель
small user social cms
Медаль
Сообщений: 423
В своем типе контента косяки, можно ставить слайдер , но там нет ограничения количества изображений scratch
Редактировалось: 1 раз (Последний: 22 января 2018 в 14:29)
Посетитель
small user social cms
Сообщений: 14
Тип поля "Изображение"
На локалке всё выводится.
На хостинге ничего не выводится с этим полем.
Конфиг хоста под Fast CGI.

убрал галочки с чекбоксов, создавать превью, как выше советовали...
на странице появилась "плашка" изображения превьюшки, но не превьюшка изображения.
нажимаю на плашку, картинка в лайтбоксе показывается.

теперь вопрос, как это побороть?

Тип поля \"Набор изображений\" не грузятся картинки
Посетитель
small user social cms
Сообщений: 14
@kibersyn:

Тип поля "Изображение"
На локалке всё выводится.
На хостинге ничего не выводится с этим полем.
Конфиг хоста под Fast CGI.

убрал галочки с чекбоксов, создавать превью, как выше советовали...
на странице появилась "плашка" изображения превьюшки, но не превьюшка изображения.
нажимаю на плашку, картинка в лайтбоксе показывается.

теперь вопрос, как это побороть?

Тип поля \"Набор изображений\" не грузятся картинки

***
с включенными чекбоксами, создаются и превьюшки и папки в upload, но в конечный фронтенд вообще никакого кода не попадает.
Редактировалось: 1 раз (Последний: 15 марта 2018 в 15:05)
Посетитель
small user social cms
Медаль
Сообщений: 103
А у вас на сервере расширение для PHP fileinfo включено?
Посетитель
small user social cms
Сообщений: 14
Alex:

А у вас на сервере расширение для PHP fileinfo включено?

extension=php_fileinfo.dll включено...

чекбоксы без галочек —> не создает превьюшки, но появляется линк на оригинальную картинку
чекбоксы с галочкой —> исчезает даже линк на оригинал
Посетитель
small user social cms
Сообщений: 14
Alex:

А у вас на сервере расширение для PHP fileinfo включено?

Тот же хостер. Загрузил свежий релиз на другой домен.
Теперь вижу нечто другое.
Вместо аватара в профиле админа ошибка:
Notice: Undefined index: normal in /home/www/второйдомен.com/system/libs/html.helper.php on line 222
За то картинки в строке изображений выводит.
Прикрепленные файлы:
1_2p2o5.png | 131,35 Кб | Скачали: 19
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.